<!doctype html><html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js"><head><meta charset="UTF-8"><link href="//www.google-analytics.com" rel="dns-prefetch"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width,initial-scale=1,minimum-scale=1,maximum-scale=1"><title>Things to Do in Canggu: 10 Ways to Enjoy the Beauty of Bali</title><script>(function(p,u,s,h) {p._pcq = p._pcq || [];p._pcq.push(['_currentTime', Date.now()]);s = u.createElement('script'); s.type = 'text/javascript'; s.async = true;s.src = 'https://cdn.pushcrew.com/js/7fa51aa9a9204c04ba768171946b2d58.js';
h = u.getElementsByTagName('script')[0]; h.parentNode.insertBefore(s, h);})(window,document);</script><meta name="description" content="You&#039;ll be able to have an incredible time no matter what your budget while in Canggu, Bali. These are some of the best things to do in Canggu."/><link rel="canonical" href="https://travel-wise.com/things-to-do-in-canggu/?all=1" /><link rel="next" href="https://travel-wise.com/things-to-do-in-canggu/2/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Things to Do in Canggu: 10 Ways to Enjoy the Beauty of Bali" /><meta property="og:description" content="You&#039;ll be able to have an incredible time no matter what your budget while in Canggu, Bali. These are some of the best things to do in Canggu." /><meta property="og:url" content="https://travel-wise.com/things-to-do-in-canggu/?all=1" /><meta property="og:site_name" content="Travel-Wise" /><meta property="article:publisher" content="https://www.facebook.com/pages/Travel-Wise/1453981954916422" /><meta property="article:tag" content="Bali" /><meta property="article:tag" content="Indonesia" /><meta property="article:tag" content="Inspiration" /><meta property="article:section" content="Destinations" /><meta property="article:published_time" content="2019-08-01T09:00:10+00:00" /><meta property="article:modified_time" content="2019-07-29T19:21:21+00:00" /><meta property="og:updated_time" content="2019-07-29T19:21:21+00:00" /><meta property="fb:app_id" content="385760331614394" /><meta property="og:image" content="https://media.travel-wise.com/wp-content/uploads/2019/07/Sunbathe-at-the-beach.jpg" /><meta property="og:image:secure_url" content="https://media.travel-wise.com/wp-content/uploads/2019/07/Sunbathe-at-the-beach.jpg" /><meta property="og:image:width" content="1140" /><meta property="og:image:height" content="555" /><meta property="og:image:alt" content="People walking on beach" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="You&#039;ll be able to have an incredible time no matter what your budget while in Canggu, Bali. These are some of the best things to do in Canggu." /><meta name="twitter:title" content="Things to Do in Canggu: 10 Ways to Enjoy the Beauty of Bali" /><meta name="twitter:image" content="https://media.travel-wise.com/wp-content/uploads/2019/07/Sunbathe-at-the-beach.jpg" /><link rel="alternate" type="application/rss+xml" title="Travel-Wise &raquo; Feed" href="https://travel-wise.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Travel-Wise &raquo; Comments Feed" href="https://travel-wise.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Travel-Wise &raquo; 10 Ways to Enjoy the Beauty of Canggu, Bali on Every Budget Comments Feed" href="https://travel-wise.com/things-to-do-in-canggu/feed/" /><link rel='stylesheet' id='wp-block-library-css' href='https://media.travel-wise.com/wp-includes/css/dist/block-library/style.min.css?ver=11663' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css' href='https://media.travel-wise.com/wp-content/themes/travelwise2/node_modules_public/font-awesome/css/font-awesome.min.css?ver=11663' type='text/css' media='all' /><link rel="stylesheet" href="https://media.travel-wise.com/wp-content/mu-plugins/minify/f=/wp-content/plugins/wp-better-attachments/assets/css/wpba-frontend.css,/wp-content/themes/travelwise2/node_modules_public/normalize.css/normalize.css,/wp-content/themes/travelwise2/dist/css/critical-path.css,/wp-content/themes/travelwise2/node_modules_public/modaal/dist/css/modaal.min.css,/wp-content/themes/travelwise2/add-to-homescreen/style/addtohomescreen.css,/wp-content/themes/travelwise2/dist/css/main.css,/wp-content/themes/travelwise2/css/ajax-pagination.css,/wp-content/themes/travelwise2/node_modules_public/slick-carousel/slick/slick.css?ver=11663" type="text/css" media="all" /><link rel='https://api.w.org/' href='https://travel-wise.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://travel-wise.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://media.travel-wise.com/wp-includes/wlwmanifest.xml" /> <meta name="generator" content="WordPress 5.0.3" /><link rel='shortlink' href='https://travel-wise.com/?p=23955' /><link rel="alternate" type="application/json+oembed" href="https://travel-wise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F" /><link rel="alternate" type="text/xml+oembed" href="https://travel-wise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F&#038;format=xml" /><script>
	var cont = 'NA';
	var ga_ltype = 'multipage';
	var ga_lux = 'default_1_1';
	var ga_ptype = 'multipage';
	var ga_pux = 'default_1_1';
</script>
<script>// must be loaded after persistence vars, and before GTM, DFP, Adsense inits
window.PERK_GDPR = window.PERK_GDPR || {};PERK_GDPR.isGdprRegion = String(window.cont).toLowerCase() == 'eu';// clear the cookie of any value
PERK_GDPR.revoke = function() {var domain = String(location.hostname);if (domain.indexOf('newlifeoutlook.com') > -1) {domain = 'newlifeoutlook.com';}var dayInSeconds = 24 * 60 * 60 * 1000;var expires = new Date((new Date().getTime()) + (-1 * dayInSeconds));document.cookie = 'PERK_GDPR_CONSENT_ALL=null;' +
'expires=' + expires +  ';domain=' + domain + ';path=/';};PERK_GDPR.getConsentValue = function() {var cookie = String(document.cookie);if (cookie.indexOf('PERK_GDPR_CONSENT_ALL=agree') > -1) {return "agree";}if (cookie.indexOf("PERK_GDPR_CONSENT_ALL=disagree") > -1) {return "disagree";}};PERK_GDPR.isConsentAllAgree = function() {return PERK_GDPR.getConsentValue() === 'agree';};PERK_GDPR.isConsentAllDisagree = function() {return PERK_GDPR.getConsentValue() === 'disagree';};PERK_GDPR.allow = function(capability) {// always allow when not a gdpr region, or if the user has already agreed
if (!PERK_GDPR.isGdprRegion || PERK_GDPR.isConsentAllAgree()) {return true;}return false;};// init 3rd party globals and functions
// gtm
window.dataLayer = window.dataLayer || [];// dfp - set ad personalization
// should happen before enableServices
window.googletag = window.googletag || {};googletag.cmd = googletag.cmd || [];googletag.cmd.push(function() {if (PERK_GDPR.allow('DFP_PERSONALIZED')) {googletag.pubads().setRequestNonPersonalizedAds(0);} else {googletag.pubads().setRequestNonPersonalizedAds(1);}});// adsense - set ad personalization
// should happen before any
// (adsbygoogle = window.adsbygoogle || []).push({});
window.adsbygoogle = window.adsbygoogle || [];if (PERK_GDPR.allow('ADSENSE_PERSONALIZED')) {adsbygoogle.requestNonPersonalizedAds=0;} else {adsbygoogle.requestNonPersonalizedAds=1;}</script><link rel="apple-touch-icon" sizes="180x180" href="https://media.travel-wise.com/wp-content/themes/travelwise2/favicons/apple-touch-icon.png"><link rel="icon" type="image/png" sizes="32x32" href="https://media.travel-wise.com/wp-content/themes/travelwise2/favicons/favicon-32x32.png"><link rel="icon" type="image/png" sizes="16x16" href="https://media.travel-wise.com/wp-content/themes/travelwise2/favicons/favicon-16x16.png"><link rel="manifest" href="https://media.travel-wise.com/manifest.json"><link rel="mask-icon" href="https://media.travel-wise.com/wp-content/themes/travelwise2/favicons/safari-pinned-tab.svg" color="#1aa6b6"><meta name="theme-color" content="#ffffff"><link id="favicon" href="https://media.travel-wise.com/wp-content/themes/travelwise2/favicons/favicon-32x32.png" rel="shortcut icon" type="image/x-icon" /><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><meta name="p:domain_verify" content="7b6461f650f3782c23a37ffe428fd95b"/><meta name="fo-verify" content="72bb55ce-9943-4e1d-a057-654e030c4949" /><meta name="B-verify" content="c1e330c5f45f1c142299b4091dd55e29a33d8fda" /><script>var PERK = window.PERK || {};PERK.themePageType = 'article page';PERK.contentGroup2 = 'article_or_listicle:destinations';PERK.interstitial = '';PERK.keywords = '';PERK.utm_medium = '';PERK.isInterstitial = false;PERK.isRevcontent = false;</script><link rel="amphtml" href="https://travel-wise.com/things-to-do-in-canggu/amp/"><script>if (PERK_GDPR.allow('TW_GTM_HEAD')) {(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-53C8XR');}</script><link rel="icon" href="https://media.travel-wise.com/wp-content/uploads/2017/09/favicon_260x260-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://media.travel-wise.com/wp-content/uploads/2017/09/favicon_260x260-1.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://media.travel-wise.com/wp-content/uploads/2017/09/favicon_260x260-1.png" /><meta name="msapplication-TileImage" content="https://media.travel-wise.com/wp-content/uploads/2017/09/favicon_260x260-1.png" /><style>#perk-gdpr-host{position:fixed;bottom:0;border:0;height:0;width:100%;overflow:hidden;background:transparent;z-index:-1}body[data-gdpr-host-mode="hidden"] #perk-gdpr-host{display:none}body[data-gdpr-host-mode]:not([data-gdpr-host-mode="hidden"]) #perk-gdpr-host{display:block;z-index:1000000}body[data-gdpr-host-mode="banner"] #perk-gdpr-host{height:200px}body[data-gdpr-host-mode="popup"] #perk-gdpr-host{height:100%;background:rgba(0,0,0,0.85)}@media screen and (max-width:480px){body[data-gdpr-host-mode="banner"] #perk-gdpr-host{height:112px}}</style><script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script><script>var googletag = googletag || {};googletag.cmd = googletag.cmd || [];googletag.cmd.push(function() {googletag.pubads().collapseEmptyDivs(true);googletag.pubads().addEventListener('slotRenderEnded', function(event) {$(document).trigger('slotRenderEnded', event);$(document).trigger('pageHeightChanged', event);});});// Perk data/functions
window.PERK = window.PERK || {};// note: sizes should be sorted smallest to largest width
PERK.renderDfp = function(opts) {try {var size = opts.sizes[0];$.each(opts.sizes, function(i, v) {if (opts.parentWidth >= v[0]) size = v;});if (opts.override && opts.override[0] === 'tablet-portrait') {if (window.innerWidth >= 768 && window.innerWidth < window.innerHeight) {size = opts.sizes[opts.override[1]];}}googletag.cmd.push(function() {googletag.defineSlot(opts.slotName, size, opts.slotId).addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});googletag.cmd.push(function() {googletag.display(opts.slotId);});} catch(err) {console.log('PERK.renderDfp', err);}};</script></head><body class="post-template-default single single-post postid-23955 single-format-standard body device-type-computer computer ppc-version-1 page-layout-1 listicle-page article-listicle-page"><script>window.fbAsyncInit = function() {FB.init({appId            : '385760331614394',autoLogAppEvents : true,xfbml            : true,version          : 'v2.10'
});FB.AppEvents.logPageView();};(function(d, s, id){var js, fjs = d.getElementsByTagName(s)[0];if (d.getElementById(id)) {return;}js = d.createElement(s); js.id = id;js.src = "//connect.facebook.net/en_US/sdk.js";
fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script><div id="main-menu" class="critical-hidden"><div class="inner"><a href="#" class="close">&times;</a><nav class="text-uppercase" aria-hidden="true" aria-labelledby="main-menu-button"><ul id="menu-travelwise_2_header_menu" class="menu"><li id="menu-item-11393" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11393"><a href="https://travel-wise.com/destinations/">Destinations</a></li><li id="menu-item-11394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11394"><a href="https://travel-wise.com/budget-travel/">Budget Travel</a></li><li id="menu-item-11395" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11395"><a href="https://travel-wise.com/adventure-travel/">Adventure Travel</a></li><li id="menu-item-11396" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11396"><a href="https://travel-wise.com/luxury-travel/">Luxury Travel</a></li><li id="menu-item-11397" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-11397"><a href="https://travel-wise.com/tips-and-planning/">Tips and Planning</a><ul class="sub-menu"><li id="menu-item-11398" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11398"><a href="https://travel-wise.com/tips-and-planning/health-and-safety/">Health and Safety</a></li><li id="menu-item-11399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11399"><a href="https://travel-wise.com/tips-and-planning/packing/">Packing</a></li><li id="menu-item-11400" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11400"><a href="https://travel-wise.com/tips-and-planning/transportation/">Transportation</a></li><li id="menu-item-11401" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11401"><a href="https://travel-wise.com/tips-and-planning/technology/">Technology</a></li><li id="menu-item-11402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11402"><a href="https://travel-wise.com/tips-and-planning/planning/">Planning</a></li><li id="menu-item-11403" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11403"><a href="https://travel-wise.com/words-of-wisdom/">Words of Wisdom</a></li></ul></li></ul></nav><form class="search-form" method="get" action="/search/"><div role="search"><label class="search-label" for="search-main-menu"></label><input class="search-input" id="search-main-menu" name="keywords" type="search" placeholder="Search" required /><input class="button" type="submit" value="Search" /></div></form></div></div><div id="wrapper"><header id="header"><div class="container"><div class="wrapper"><div class="wrapper-left critical-hidden"><a id="main-menu-button" class="main-menu-button" href="#main-menu" aria-label="Main Menu" aria-expanded="false" aria-controls="main-menu"><span class="bg-icon bg-icon-svg three-dots white-three-dots"></span></a></div><div class="wrapper-center"><a href="/"><img src="https://media.travel-wise.com/wp-content/themes/travelwise2/img/logo.png" alt="Travel-Wise" title="Travel-Wise" /></a></div><div class="wrapper-right critical-hidden"><a class="header-search-button" href="#search"
aria-label="Search" aria-expanded="false" aria-controls="header-search-form"><span aria-hidden="true"><span class="bg-icon bg-icon-svg search white-search"></span></span></a></div></div></div></header><div id="header-search-form" class="critical-hidden"><div class="container"><a href="#" class="close">&times;</a><form class="search-form" method="get" action="/search/"><div role="search"><label class="search-label" for="search-header"></label><input class="search-input" id="search-header" name="keywords" type="search" placeholder="Search" required /><input class="button" type="submit" value="Search" /></div></form></div></div><div id="main-outer-wrapper"><div class="header-image-wrapper"><div class="container"><div class="image-wrapper header-image "><div class="image background-image cover-image" style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2019/07/Hit-the-Surf-750x375.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2019/07/Hit-the-Surf-750x375.jpg" alt="People in the water with their surfboards" title="People in the water with their surfboards" /></div><div class="image-text-overlay"><div class="caption">Batu Bolong Beach is a surfer's paradise.</div><div class="source-credit">Photo Credit: <a href="http://www.gettyimages.com" target="_blank" rel="nofollow noopener">Getty Images</a></div></div></div></div></div><div id="main-inner-wrapper"><main id="main"><div class="container padding"><article class="article single-article"><ul class="breadcrumb"><li class="home"><a href="/"><span class="sr-only">Home</span></a></li><li><a href="https://travel-wise.com/destinations/">Destinations</a></li></ul><h1 class="post-title">10 Ways to Enjoy the Beauty of Canggu, Bali on Every Budget</h1><div class="byline-wrapper"><div class="authors-bylines-wrapper"><div class="authors-bylines"><div class="authors-byline"><div class="author-image"><img src="https://media.travel-wise.com/wp-content/uploads/2019/07/Yaz-Purnell-85x85.jpg" width="1" height="1" alt="Yasmin Purnell" class="avatar avatar-1 wp-user-avatar wp-user-avatar-1 alignnone photo" /></div><div class="byline-root"><a class="author-link js-hover-bio" href="javascript:void(0);">Yasmin Purnell</a><div class="hover-bio hide"><div class="hover-bio-inner">Yaz Purnell is a freelance writer and the founder of The Wallet Moth, where she shares practical personal finance tips and insights into managing a location independent business while traveling the world.</div></div></div></div></div><div class="date-wrapper"><span class="separator">&nbsp;&nbsp;/&nbsp;&nbsp;</span><span class="date">August 1, 2019</span></div></div><ul class="social-links single-social-sharing-links"><li class="facebook"><a class="link-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DFacebook%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Facebook Share"><span class="bg-icon bg-icon-svg facebook white-facebook"></span><span class="sr-only">facebook</span></a></li><li class="bookmark"><a class="link-bookmark" href="https://travel-wise.com/things-to-do-in-canggu/?utm_source=Bookmark&utm_medium=Social&utm_content=Article_Share" rel="nofollow" target="_blank" data-share="Bookmark Share"><span class="bg-icon bg-icon-svg bookmark white-bookmark"></span><span class="sr-only">bookmark</span></a></li><li class="messenger"><a class="link-messenger" href="https://travel-wise.com/things-to-do-in-canggu/?utm_source=Messenger&utm_medium=Social&utm_content=Article_Share" rel="nofollow" target="_blank" data-share="Messenger Share"><span class="bg-icon bg-icon-svg messenger white-messenger"></span><span class="sr-only">messenger</span></a></li><li class="pinterest"><a class="link-pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DPinterest%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Pinterest Share"><span class="bg-icon bg-icon-svg pinterest white-pinterest"></span><span class="sr-only">pinterest</span></a></li><li class="twitter"><a class="link-twitter" href="https://twitter.com/share?url=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DTwitter%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Twitter Share"><span class="bg-icon bg-icon-svg twitter white-twitter"></span><span class="sr-only">twitter</span></a></li><li class="email"><a class="link-email" href="mailto:?Subject=Checkout%20Travelwise%20-%20Great%20Travel%20Site!&body=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DEmail%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Email Share"><span class="bg-icon bg-icon-svg email white-email"></span><span class="sr-only">email</span></a></li></ul></div><div class="content"><h2>Stunning Sunsets and Unfathomable Food</h2><p>It’s no secret that Bali is a top travel destination for anyone craving beautiful beaches, breathtaking rice paddy views and good vibes all round.</p><p>Visiting Bali feels like coming home to a long-lost family, and recently I was fortunate enough to spend an entire month soaking up the charm of Canggu, a beach-town rising in popularity for its laid-back surfer vibe, amazing food and stunning sunsets.</p><p>As a freelance writer, I’m lucky enough to be able to dip my toes into the <a href="https://www.thewalletmoth.com/become-a-freelance-writer/" target="_blank" rel="noopener">&#8220;digital nomad&#8221; lifestyle</a> when I like, and that meant I got to take my laptop with me to Bali and experience the best Canggu had to offer while still working.</p><p>You could really be on any budget and still have an epic time in Canggu. The food is cheap, most places are within walking distance (although scooter rentals are very affordable), and there are accommodation options for backpackers right through to luxury holiday-makers.</p><p>Read on to discover some of the best things to do in Canggu when you visit!</p><ins class="adsbygoogle TravelWise_Upper_Responsive ad-unit ad"
data-ad-client="ca-pub-9467586861738328"
data-ad-slot="5206802807"></ins><script>(adsbygoogle = window.adsbygoogle || []).push({});</script><h3>Hit the Surf</h3><p>There’s surfing for everybody in Canggu, whether you’ve never laid hands on a surfboard, or have been catching waves for years.</p><p>Batu Bolong Beach is literally lined with surf shops where you can rent a board or have a lesson for an hour or two. The friendly surf instructors are often locals who have grown up reading waves since they were kids.</p><p>If you’re an experienced surfer, head to Echo Beach — or just go there to watch the experts riding insane waves!</p><p class="content-image alignnone size-full wp-image-23986"><img src="https://media.travel-wise.com/wp-content/uploads/2019/07/Take-a-Yoga-Class-750x375.jpg"
data-guid="https://media.travel-wise.com/wp-content/uploads/2019/07/Take-a-Yoga-Class.jpg"
alt="Someone sitting with hands on knees outside doing yoga"
title="Someone sitting with hands on knees outside doing yoga" /><span class="content-image-overlay"><span class="content-image-caption">Try out a yoga class while in Bali. There are so many to choose from.</span><span class="content-image-source-credit">Photo Credit: <a href="http://www.gettyimages.com" target="_blank" rel="nofollow noopener">Getty Images</a></span></span></p><h3>Take a Yoga Class</h3><p>Yoga is synonymous with Bali — you really don’t have to look very far to find a quality yoga class taught by a talented teacher.</p><p>Make sure you check out the classes at <a href="https://www.serenitybali.com/" target="_blank" rel="noopener">Serenity Eco Guesthouse</a>, which has a full schedule of classes all day long, including the chance to try some fun new things like aerial yoga. Head to their raw vegan cafe, Alkaline, afterward to try one of their amazing vegan cakes!</p><div class="seealso-you-may-like-wrapper critical-hidden"><div class="you-may-like-wrapper"><div class="title">You May Also Like:</div><div class="you-may-like"><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/10/Marquesas-compressed-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/10/Marquesas-compressed-360x240.jpg" alt="Harbor with sailboats and green mountains in background" title="Harbor with sailboats and green mountains in background" /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/marquesas-islands-tahiti/">Marquesas Islands, Tahiti</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link " href="https://travel-wise.com/author/meevans/">Marissa Evans</a> / <span class="date">December 8, 2011</span></p></div></div></div></div><div class="article-extended"><div class="excerpt"><p>Stunning Sunsets and Unfathomable Food It’s no secret that Bali is a top travel destination for anyone craving beautiful beaches, breathtaking rice paddy...</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/preparation/">Preparation</a></div></div></article></div></div><div class="see-also-wrapper "><div class="title">See Also:</div><div class="seealso">
<div class="seealso1"><div class="seealsotext"><a class="" rel="nofollow" target="_blank" href="/see-also-results/?keywords=botswana+tours+and+safaris">Botswana Tours &amp; Safaris</a></div></div>
<div class="seealso2"><div class="seealsotext"><a class="" rel="nofollow" target="_blank" href="/see-also-results/?keywords=discount+travel+deals">Discount Travel Deals</a></div></div>
<div class="seealso3"><div class="seealsotext"><a class="" rel="nofollow" target="_blank" href="/see-also-results/?keywords=cheap+hotels">Cheap Hotels</a></div></div>
<div class="seealso4"><div class="seealsotext"><a class="" rel="nofollow" target="_blank" href="/see-also-results/?keywords=city+of+london+tours">London City Tours</a></div></div>
<div class="seealso5"><div class="seealsotext"><a class="" rel="nofollow" target="_blank" href="/see-also-results/?keywords=low+cost+hotels+in+san+francisco">Hotels in San Francisco</a></div></div>
</div>
</div></div><p class="content-image alignnone size-full wp-image-23987"><img src="https://media.travel-wise.com/wp-content/uploads/2019/07/Foodie-Tour-750x375.jpg"
data-guid="https://media.travel-wise.com/wp-content/uploads/2019/07/Foodie-Tour.jpg"
alt="Smoothie bowl"
title="Smoothie bowl" /><span class="content-image-overlay"><span class="content-image-caption">There are so many delicious foods to indulge in while in Bali.</span><span class="content-image-source-credit">Photo Credit: <a href="https://www.thewalletmoth.com/" target="_blank" rel="nofollow noopener">The Wallet Moth</a></span></span></p><h3>Foodie Tour</h3><p>The food in Canggu is unparalleled. From local nasi campur (rice with side dishes) to epic brunches, vegan burgers and even an <a href="https://www.theavocadofactory.com/" target="_blank" rel="noopener">all-avocado restaurant</a>, there’s literally something for everyone — and always at great prices.</p><p>My top recommendations would be:</p><ul><li><a href="https://www.facebook.com/Theshadyshackbali/" target="_blank" rel="noopener">The Shady Shack</a>: for vegetarian and vegan feasting</li><li><a href="https://www.theloftbali.co/" target="_blank" rel="noopener">The Loft</a>: for a great ambiance and delicious food</li><li><a href="https://www.facebook.com/motioncafebali/" target="_blank" rel="noopener">Motion Cafe</a>: for health-focused dining</li><li><a href="https://www.labaraccabali.com/" target="_blank" rel="noopener">La Baracca</a>: delicious pizza (with vegan options!)</li><li><a href="http://www.pelotonsupershop.com/" target="_blank" rel="noopener">Peleton Supershop</a>: for beautiful decor and vegan food heaven</li><li><a href="https://www.facebook.com/cafevidabali/" target="_blank" rel="noopener">Cafe Vida</a>: beautiful setting and great options for everyone</li></ul><p>Honestly, though, I never had a bad meal in Canggu. Make sure you head into one of the busier local warungs to try nasi campur, nasi goreng or mie goreng!</p></div></article><div class="after-content critical-hidden"><div class="pagination"><div class="prev-wrapper"></div><div class="next-wrapper"><a class="next cta-link" href="https://travel-wise.com/things-to-do-in-canggu/2/">Next</a></div></div><div class="end-of-content"></div><div id='div-gpt-ad-1500320244320-0' class="ad-unit ad TravelWise_Lower"></div><div class="post-comments"><a href="#" class="toggle-comments cta-link text-uppercase">Comments <span>+</span></a><div class="comments"><div class="fb-comments" data-href="https://travel-wise.com/things-to-do-in-canggu/" data-width="100%"></div></div></div><div class="article-tags"><dl><dt>Tags:</dt><dd><ul class="menu"><li><a href="https://travel-wise.com/tag/inspiration/">Inspiration</a></li><li><a href="https://travel-wise.com/tag/indonesia/">Indonesia</a></li><li><a href="https://travel-wise.com/tag/bali/">Bali</a></li></ul></dd></dl></div><div class="related-articles-mobile"><div class="related-articles"><div class="row row-title"><h5 class="title text-uppercase">Related Articles</h5></div><div class="row row-articles articles"><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2019/07/Lisbon-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2019/07/Lisbon-360x240.jpg" alt="Colorful buildings" title="Colorful buildings" /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/things-to-do-in-lisbon/">3 Ways to Have an Immersive Cultural Experience in Lisbon</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link js-hover-bio" href="javascript:void(0);">Abigail David</a> / <span class="date">July 23, 2019</span></p><div class="hover-bio hide"><div class="hover-bio-inner">Abby is a Vancouver native currently living in Toronto, Canada. Over the past five years, she has traveled to over 40 countries and is an avid solo female traveler. Abby also lives with a chronic illness (type 1 diabetes) and shares her stories and experiences traveling with a chronic illness. When she's not traveling, Abby is a professional musician, writer and self-proclaimed craft chocolate connoisseur!</div></div></div></div></div></div><div class="article-extended"><div class="excerpt"><p>If you're looking to soak up Portugese culture — from food to music to literature — the following are the best things to do in Lisbon.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2019/05/Sayan-villa-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2019/05/Sayan-villa-360x240.jpg" alt="Deck with pool." title="Deck with pool." /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/bali-twice-the-magic/">Rich Experiences Await with the Bali Twice the Magic Package Through Four Seasons</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link " href="https://travel-wise.com/author/monte-mathews/">Monte Mathews</a> / <span class="date">May 21, 2019</span></p></div></div></div></div><div class="article-extended"><div class="excerpt"><p>With the Bali Twice the Magic package you'll be able to experience 2 Four Seasons resorts, getting a taste for different landscapes in Bali.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2019/07/Madrid-2-edited-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2019/07/Madrid-2-edited-360x240.jpg" alt="Plaza in Madrid with lots of people" title="Plaza in Madrid with lots of people" /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/things-to-do-in-madrid/">Get Away from the Crowds and Discover What These Colorful Neighborhoods in Madrid Have to Offer</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link js-hover-bio" href="javascript:void(0);">Abigail David</a> / <span class="date">July 25, 2019</span></p><div class="hover-bio hide"><div class="hover-bio-inner">Abby is a Vancouver native currently living in Toronto, Canada. Over the past five years, she has traveled to over 40 countries and is an avid solo female traveler. Abby also lives with a chronic illness (type 1 diabetes) and shares her stories and experiences traveling with a chronic illness. When she's not traveling, Abby is a professional musician, writer and self-proclaimed craft chocolate connoisseur!</div></div></div></div></div></div><div class="article-extended"><div class="excerpt"><p>While you'll certainly want to visit the touristy center of the city, some of the best things to do in Madrid are found in its colorful neighborhoods.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2011/12/Banff-2-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2011/12/Banff-2-360x240.jpg" alt="Overlooking town of Banff with mountain in background" title="Overlooking town of Banff with mountain in background" /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/north-america-travel-guide/">7 Culturally & Naturally Diverse Destinations to Visit in North America</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link " href="https://travel-wise.com/author/kelly/">Kelly Dunning</a> / <span class="date">July 18, 2019</span></p></div></div></div></div><div class="article-extended"><div class="excerpt"><p>You won't even come close to seeing it all, but these destinations in North America will introduce you to some incredible cultures and natural landscapes.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article></div></div></div></div></div></main><aside id="sidebar" class="critical-hidden"><div class="container padding"><div class="cta-stay-updated cta-block"> <h4 class="section-title">Stay updated!</h4> <p class="section-sub-title">Subscribe to our newsletter to receive updates &amp; receive a <span class="text-uppercase">Free Travel Ebook!</span></p> <a href="#" class="cta-link">Get Your Free Ebook Now!</a> <form class="form" action="/" method="post" novalidate> <input type="hidden" name="action" value="submit_newsletter" /> <p class="location-instructions">To help us customize your newsletter experience, let us know which country you currently reside in.</p> <fieldset class="location"> <legend class="sr-only">Country:</legend> <div class="field-country-us field-radio field"> <input id="cta-stay-updated-country-us" type="radio" name="country" value="us" required /> <label for="cta-stay-updated-country-us">US</label> </div> <div class="field-country-uk field-radio field"> <input id="cta-stay-updated-country-uk" type="radio" name="country" value="uk" required /> <label for="cta-stay-updated-country-uk">UK</label> </div> <div class="field-country-other field-radio field"> <input id="cta-stay-updated-country-other" type="radio" name="country" value="other" required /> <label for="cta-stay-updated-country-other">Other</label> </div> </fieldset> <a href="#" class="fb-button-subscribe">Subscribe with Facebook</a> <div class="email-instructions">or subscribe via email</div> <div class="email-submit-wrapper"> <div class="field-email field-input field"> <label for="cta-stay-updated-email" class="sr-only">Email</label> <input id="cta-stay-updated-email" name="email" placeholder="Email" type="text" required /> </div> <div class="field-submit field"> <button type="submit">Sign Up</button> <span class="loading"></span> </div> </div> <div class="response"></div></form></div><div id='div-gpt-ad-1500320945374-0' class="ad-unit ad TravelWise_Sidebar"></div><div class="cta-block cta-from-the-road text-center"><h4 class="section-title">From the <span>Road</span></h4><p>Have a travel memory you’d like to share? Whether it was funny, disastrous, unexpected, or simply enjoyable, we want to hear a story from your vacation.</p><a href="/from-the-road-form/" class="cta-link">Share Your Adventures</a></div><div class="cta-block cta-follow-us text-center"><h4 class="section-title">Follow Us</h4><ul class="menu social-links "><li class="facebook"><a class="link-facebook" href="https://www.facebook.com/travelwisecom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg facebook blue-facebook"></span><span class="sr-only">facebook</span></a></li><li class="twitter"><a class="link-twitter" href="https://twitter.com/TravelWiseCom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg twitter blue-twitter"></span><span class="sr-only">twitter</span></a></li><li class="pinterest"><a class="link-pinterest" href="https://www.pinterest.com/travelwisecom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg pinterest blue-pinterest"></span><span class="sr-only">pinterest</span></a></li><li class="youtube"><a class="link-youtube" href="https://www.youtube.com/channel/UClXXZYQCh_-m26ijquIep_g?gl=US" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg youtube blue-youtube"></span><span class="sr-only">youtube</span></a></li><li class="instagram"><a class="link-instagram" href="https://www.instagram.com/travelwisecom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg instagram blue-instagram"></span><span class="sr-only">instagram</span></a></li></ul> </div><div class="cta-block cta-words-of-wisdom mode-small"><h4 class="section-title"><a href="/words-of-wisdom/">Words of <span>Wisdom</span></a></h4><div class="slider-wrapper"><div class="slider loading"><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2018/05/IMG_1291-768x576.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2018/05/IMG_1291-768x576.jpg" alt="" title="SarahR-Words-of-Wisdom" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content">Check your airline's prices for additional and overweight baggage. It is sometimes cheaper to take an extra bag than pay overage fees if your luggage is too heavy.</div><div class="byline">- Sarah R., Canada</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2018/01/Zainab-Words-of-Wisdom-768x511.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2018/01/Zainab-Words-of-Wisdom-768x511.jpg" alt="" title="Zainab-Words-of-Wisdom" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content"><span style="font-weight: 400;">Don’t eat in tourist areas or places that have a waiter outside to bring people in. Eat where the locals eat.</span></div><div class="byline">- Zainab L., United Kingdom</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2018/01/Mona-Words-of-Wisdom-768x512.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2018/01/Mona-Words-of-Wisdom-768x512.jpg" alt="" title="Mona-Words-of-Wisdom" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content"><span style="font-weight: 400;">Never bring new shoes! Bring two pairs of shoes to allow you to rotate and avoid any discomfort to your feet.</span></div><div class="byline">- Mona W., Belize</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/12/Laura-G-Words-of-Wisdom-768x554.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/12/Laura-G-Words-of-Wisdom-768x554.jpg" alt="" title="Laura S - Words of Wisdom" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content"><span style="font-weight: 400;">Do your research; learn about where you’re going from those who have been there. You’ll learn lots more along the way.</span></div><div class="byline">- Laura S., United States</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/12/WOW-Sam-SOS-Travel.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/12/WOW-Sam-SOS-Travel.jpg" alt="" title="SOS Travel - Words of Wisdom" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content"><span style="font-weight: 400;">When you land in Geneva make sure to pick up your free transport ticket in the luggage collection area, from the machine. It gives you 80 minutes worth of travel from arrival, until you get to your hotel or accommodation.</span></div><div class="byline">- SOS Travel, United Kingdom</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/09/ndevine_hamilton-ontario-hiking_websters-falls-768x576.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/09/ndevine_hamilton-ontario-hiking_websters-falls-768x576.jpg" alt="A small river flows through trees" title="WoW - Natasha Devine" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content">Always bring a reusable water bottle for each person. There's nothing worse than being on a hike or walking through a new city and finding yourself without water. If you're in a city most restaurants will refill your bottle free of charge!</div><div class="byline">- Natasha, Canada</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/09/melanie-768x513.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/09/melanie-768x513.jpg" alt="" title="WoW - Melanie Grosjean" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content"><span style="font-weight: 400;">Don’t be too rushed when you are traveling, especially with kids. Taking it slow helps you to experience everything going on around you and cuts down on the stress that comes from rushing from place to place. Don’t worry about missing out. Live in the moment and soak it all in.</span></div><div class="byline">- Melanie, Thailand</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/09/apple-iphone-smartphone-768x493.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/09/apple-iphone-smartphone-768x493.jpg" alt="" title="WoW - Loren" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content"><span style="font-weight: 400;">Nothing ruins a vacation like being unable to charge your electronic devices. So make sure to carry a power-cord organizer with you! Cocoon Innovations’ GRID-IT! pouches can accommodate any sort of cord or charger, making them a convenient choice, and they’re remarkably slim.</span></div><div class="byline">- Loren, United States</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/09/Liana-768x495.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/09/Liana-768x495.jpg" alt="" title="WoW - Liana Minassian" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content"><span style="font-weight: 400;">When traveling, don’t forget to take the road less traveled once in awhile. Travel should get you outside your comfort zone so you can learn new things about yourself and who you truly are. Don’t be afraid to take some risks (within reason) and leave room for spontaneity.</span></div><div class="byline">- Liana, United States</div></div></div><div class="slide"><div class="image background-image align-top" style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/09/Kelly-wordsofwisdom.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/09/Kelly-wordsofwisdom.jpg" alt="" title="Kelly - Words of Wisdom" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content">My boyfriend Lee and I are big fans of overnight buses and trains because you can save the cost of accommodation and you won't waste one of your precious travel days getting somewhere. Just be sure to bring earplugs, an eye mask and a sarong to use as a blanket or pillow!</div><div class="byline">- Kelly, United Kingdom</div></div></div><div class="slide"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2017/09/Trinity-NL-768x406.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2017/09/Trinity-NL-768x406.jpg" alt="" title="WoW - K.C. Dermody" /></div><div class="slide-content-wrapper" style="display:none;"><div class="content">Always check the seat pocket to be sure you don’t leave any important items on the plane. I once forgot my passport in the seat pocket, which I needed to get home. Thankfully, I was able to retrieve it. Lesson learned!</div><div class="byline">- K.C., United States</div></div></div></div></div><div class="content-wrapper"></div><a href="/words-of-wisdom-form/" class="cta-link">Send us your W.O.W.</a></div><div class="cta-block cta-work-with-us"><h4 class="section-title">Work <span>With us</span></h4><p>We’re always on the lookout for talented individuals who will add value to our website. Are you interested in becoming part of the Travel-Wise team? We’d love to <span class="nowrap">hear from you!</span></p><a class="cta-link" href="/work-with-us-form/">Apply to be a contributor</a></div></div></aside></div><div class="related-articles-tablet-landscape-and-desktop"><div class="container padding"><div class="related-articles"><div class="row row-title"><h5 class="title text-uppercase">Related Articles</h5></div><div class="row row-articles articles"><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2019/07/Lisbon-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2019/07/Lisbon-360x240.jpg" alt="Colorful buildings" title="Colorful buildings" /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/things-to-do-in-lisbon/">3 Ways to Have an Immersive Cultural Experience in Lisbon</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link js-hover-bio" href="javascript:void(0);">Abigail David</a> / <span class="date">July 23, 2019</span></p><div class="hover-bio hide"><div class="hover-bio-inner">Abby is a Vancouver native currently living in Toronto, Canada. Over the past five years, she has traveled to over 40 countries and is an avid solo female traveler. Abby also lives with a chronic illness (type 1 diabetes) and shares her stories and experiences traveling with a chronic illness. When she's not traveling, Abby is a professional musician, writer and self-proclaimed craft chocolate connoisseur!</div></div></div></div></div></div><div class="article-extended"><div class="excerpt"><p>If you're looking to soak up Portugese culture — from food to music to literature — the following are the best things to do in Lisbon.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2019/05/Sayan-villa-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2019/05/Sayan-villa-360x240.jpg" alt="Deck with pool." title="Deck with pool." /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/bali-twice-the-magic/">Rich Experiences Await with the Bali Twice the Magic Package Through Four Seasons</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link " href="https://travel-wise.com/author/monte-mathews/">Monte Mathews</a> / <span class="date">May 21, 2019</span></p></div></div></div></div><div class="article-extended"><div class="excerpt"><p>With the Bali Twice the Magic package you'll be able to experience 2 Four Seasons resorts, getting a taste for different landscapes in Bali.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2019/07/Madrid-2-edited-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2019/07/Madrid-2-edited-360x240.jpg" alt="Plaza in Madrid with lots of people" title="Plaza in Madrid with lots of people" /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/things-to-do-in-madrid/">Get Away from the Crowds and Discover What These Colorful Neighborhoods in Madrid Have to Offer</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link js-hover-bio" href="javascript:void(0);">Abigail David</a> / <span class="date">July 25, 2019</span></p><div class="hover-bio hide"><div class="hover-bio-inner">Abby is a Vancouver native currently living in Toronto, Canada. Over the past five years, she has traveled to over 40 countries and is an avid solo female traveler. Abby also lives with a chronic illness (type 1 diabetes) and shares her stories and experiences traveling with a chronic illness. When she's not traveling, Abby is a professional musician, writer and self-proclaimed craft chocolate connoisseur!</div></div></div></div></div></div><div class="article-extended"><div class="excerpt"><p>While you'll certainly want to visit the touristy center of the city, some of the best things to do in Madrid are found in its colorful neighborhoods.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article><article class="article preview-article"><div class="image-wrapper"><div class="image background-image " style="background-image: url(https://media.travel-wise.com/wp-content/uploads/2011/12/Banff-2-360x240.jpg);"><img style="display:none !important;" src="https://media.travel-wise.com/wp-content/uploads/2011/12/Banff-2-360x240.jpg" alt="Overlooking town of Banff with mountain in background" title="Overlooking town of Banff with mountain in background" /></div><div class="image-text-overlay"><h4 class="post-title"><a href="https://travel-wise.com/north-america-travel-guide/">7 Culturally & Naturally Diverse Destinations to Visit in North America</a></h4><div class="byline"><div class="byline-root"><p><a class="author-link " href="https://travel-wise.com/author/kelly/">Kelly Dunning</a> / <span class="date">July 18, 2019</span></p></div></div></div></div><div class="article-extended"><div class="excerpt"><p>You won't even come close to seeing it all, but these destinations in North America will introduce you to some incredible cultures and natural landscapes.</p></div><div class="category-tag-wrapper"><a class="category text-uppercase" href="https://travel-wise.com/destinations/">Destinations</a><a class="tag text-uppercase" href="https://travel-wise.com/tag/inspiration/">Inspiration</a></div></div></article></div></div></div></div></div><div id="footer-instagram" class="instagram end-of-page"><div class="container"><div class="images"><div class="image-wrapper count-1"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/d92cce3964f38883a998c39efa03a39e/5DED5C12/t51.2885-15/e35/s320x320/64935639_348381872754537_288157515810300825_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-2"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/0077d8a74d16ac1981392284638f2ac5/5DCA1FB1/t51.2885-15/e15/s320x320/65851678_494329021370181_5190682689915377483_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-3"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/4e63ca489be6e95c7e94cad11e42c010/5DD81B9D/t51.2885-15/e15/s320x320/66719980_707562619714226_4858414257869065664_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-4"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/37657df555bfa8bdb3eb192e6713dcac/5DDA9575/t51.2885-15/e15/s320x320/62421045_2235779603207476_3463910598793638692_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-5"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/067842b7c4314f7712bcc0874f519b2b/5DC79F3A/t51.2885-15/e15/s320x320/65301906_1094685674049851_9092245547365331769_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-6"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/34c18d62b3b569e8cdc3ca180a2f902c/5DE4FDBE/t51.2885-15/e15/s320x320/63031239_1053584084846756_740538278895585667_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-7"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/efc0b42c18cf1883cdd8287aedf7dc81/5DC96F6D/t51.2885-15/e35/s320x320/66402741_105383064003476_4235404802166714710_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-8"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/03e0708feee0367d07a403fbf50e8138/5DD42200/t51.2885-15/e15/s320x320/66149543_472765976817774_5327300249074858928_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div><div class="image-wrapper count-9"><div class="image background-image " style="background-image: url(https://scontent.cdninstagram.com/vp/75cf13894cb4df098a684161b1b80b55/5DE36AC7/t51.2885-15/e15/s320x320/64717712_427179624549914_6525283675679020330_n.jpg?_nc_ht=scontent.cdninstagram.com);"></div></div></div><div class="cta-link-wrapper"><a class="cta-link instagram-cta-link text-uppercase" href="https://www.instagram.com/travelwisecom/" rel="nofollow">Follow us @travelwisecom</a></div></div></div><footer id="footer"><div class="container padding"><div><div class="logo"><a href="/"><img src="https://media.travel-wise.com/wp-content/themes/travelwise2/img/logo.png" alt="Travel-Wise" title="Travel-Wise" /></a></div></div><div class="search-form-wrapper"><form class="search-form" method="get" action="/search/"><div role="search"><label class="search-label" for="search-footer"></label><input class="search-input" id="search-footer" name="keywords" type="search" placeholder="Search" required /><input class="button" type="submit" value="Search" /></div></form></div><div class="social-wrapper"><div class="social"><div class="social-title text-uppercase"><strong>Connect with us:</strong></div><ul class="menu social-links "><li class="facebook"><a class="link-facebook" href="https://www.facebook.com/travelwisecom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg facebook white-facebook"></span><span class="sr-only">facebook</span></a></li><li class="twitter"><a class="link-twitter" href="https://twitter.com/TravelWiseCom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg twitter white-twitter"></span><span class="sr-only">twitter</span></a></li><li class="pinterest"><a class="link-pinterest" href="https://www.pinterest.com/travelwisecom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg pinterest white-pinterest"></span><span class="sr-only">pinterest</span></a></li><li class="youtube"><a class="link-youtube" href="https://www.youtube.com/channel/UClXXZYQCh_-m26ijquIep_g?gl=US" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg youtube white-youtube"></span><span class="sr-only">youtube</span></a></li><li class="instagram"><a class="link-instagram" href="https://www.instagram.com/travelwisecom/" rel="nofollow" target="_blank" ><span class="bg-icon bg-icon-svg instagram white-instagram"></span><span class="sr-only">instagram</span></a></li></ul> </div><nav><ul id="menu-travelwise_2_footer_menu" class="menu"><li id="menu-item-11404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11404"><a href="https://travel-wise.com/contributors/">Contributors</a></li><li id="menu-item-11405" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11405"><a href="https://travel-wise.com/about-us/">About Us</a></li><li id="menu-item-11406" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11406"><a href="https://travel-wise.com/contact-us/">Contact Us</a></li><li id="menu-item-11407" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11407"><a href="https://travel-wise.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-11665" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11665"><a href="https://travel-wise.com/terms-of-use/">Terms of Use</a></li></ul></nav></div></div></footer><div id="copyright"><div class="container padding"><p>&copy; 2019 travel-wise™ All rights reserved.</p><nav><ul id="menu-travelwise_2_footer_menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11404"><a href="https://travel-wise.com/contributors/">Contributors</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11405"><a href="https://travel-wise.com/about-us/">About Us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11406"><a href="https://travel-wise.com/contact-us/">Contact Us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11407"><a href="https://travel-wise.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-11665"><a href="https://travel-wise.com/terms-of-use/">Terms of Use</a></li></ul></nav></div></div><div id="footer-social-bar" class="footer-social-bar-element"><div class="container padding"><div class="wrapper"><div class="wrapper-left"><a class="link-bookmark" href="https://travel-wise.com/things-to-do-in-canggu/?utm_source=Bookmark&utm_medium=Social&utm_content=Article_Share" rel="nofollow" target="_blank" data-share="Bookmark Share"><span class="bg-icon bg-icon-svg bookmark blue-bookmark"></span><span class="sr-only">bookmark</span></a></div><div class="wrapper-center"><a class="social-bar-button-share text-uppercase" href="#">Share</a><div class="wrapper-social-links"><ul class="menu social-links"><li class="pinterest"><a class="link-pinterest" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DPinterest%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Pinterest Share"><span class="bg-icon bg-icon-svg pinterest blue-pinterest"></span><span class="sr-only">pinterest</span></a></li><li class="twitter"><a class="link-twitter" href="https://twitter.com/share?url=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DTwitter%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Twitter Share"><span class="bg-icon bg-icon-svg twitter blue-twitter"></span><span class="sr-only">twitter</span></a></li><li class="messenger"><a class="link-messenger" href="https://travel-wise.com/things-to-do-in-canggu/?utm_source=Messenger&utm_medium=Social&utm_content=Article_Share" rel="nofollow" target="_blank" data-share="Messenger Share"><span class="bg-icon bg-icon-svg messenger blue-messenger"></span><span class="sr-only">messenger</span></a></li><li class="facebook"><a class="link-facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DFacebook%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Facebook Share"><span class="bg-icon bg-icon-svg facebook blue-facebook"></span><span class="sr-only">facebook</span></a></li></ul></div></div><div class="wrapper-right"><a class="link-email" href="mailto:?Subject=Checkout%20Travelwise%20-%20Great%20Travel%20Site!&body=https%3A%2F%2Ftravel-wise.com%2Fthings-to-do-in-canggu%2F%3Futm_source%3DEmail%26utm_medium%3DSocial%26utm_content%3DArticle_Share" rel="nofollow" target="_blank" data-share="Email Share"><span class="bg-icon bg-icon-svg email blue-email"></span><span class="sr-only">email</span></a></div></div></div></div><div id="footer-social-bar-vertical-space" class="footer-social-bar-element">&nbsp;</div></div><script type="application/ld+json">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</script><script src="https://media.travel-wise.com/wp-content/mu-plugins/minify/f=/wp-content/themes/travelwise2/node_modules_public/jquery/dist/jquery.min.js,/wp-content/themes/travelwise2/node_modules_public/lodash/lodash.min.js,/wp-content/themes/travelwise2/node_modules_public/ua-parser-js/dist/ua-parser.min.js,/wp-content/themes/travelwise2/node_modules_public/bluebird/js/browser/bluebird.min.js,/wp-includes/js/imagesloaded.min.js,/wp-content/themes/travelwise2/impetus.js,/wp-content/themes/travelwise2/node_modules_public/jquery-visible/jquery.visible.min.js,/wp-content/themes/travelwise2/node_modules_public/modaal/dist/js/modaal.min.js,/wp-content/themes/travelwise2/add-to-homescreen/src/addtohomescreen.min.js,/wp-content/themes/travelwise2/dist/js/main.js,/wp-content/themes/travelwise2/node_modules_public/slick-carousel/slick/slick.min.js?ver=11663"></script><script>jQuery(function($) {PERK.renderDfp({parentWidth: $('#main > .container').width(),sizes: [[300, 250], [336, 280], [468, 60], [728, 90]],slotName: '/6433121/TravelWise_Lower',slotId: 'div-gpt-ad-1500320244320-0'
});});</script><script>jQuery(function($) {PERK.renderDfp({parentWidth: $('#sidebar > .container').width(),sizes: [[300, 250], [336, 280]],slotName: '/6433121/TravelWise_Sidebar',slotId: 'div-gpt-ad-1500320945374-0',override: ['tablet-portrait', 0]
});});</script><iframe id="perk-gdpr-host" style="display: none;" data-src="/gdpr/loader/1554318398701/"></iframe><script>// GDPR HOST
// NOTE: vanilla js only, no es6, no dependencies
// host is what loads within the actual outer website, not within the iframe
// used to load iframe, pass messages, and control the size/position of the iframe
// scope wrapper
;(function() {// if not gdpr region, just exit
if (!window.PERK_GDPR.isGdprRegion) {return;}function stopEvent(e) {try {e.preventDefault()
e.stopPropagation()
} catch (e) {// pass
}}function elHasClass(el, className) {return String(el.className).trim().split(' ').indexOf(className) > -1
}// dom ready
// - add iframe src and unhide
// - revoke click event handler
document.addEventListener('DOMContentLoaded', function() {var iframe = document.getElementById('perk-gdpr-host')
setTimeout(function() {iframe.setAttribute('src', iframe.getAttribute('data-src'))
iframe.removeAttribute('style')
})
document.addEventListener('click', function (e) {if (!elHasClass(e.target, 'perk-gdpr-revoke')) {return
}stopEvent(e)
PERK_GDPR.revoke()
alert('GDPR Consent Revoked')
});})
// message from iframe
// only listen for gdpr-host messages
// execute supported actions
window.addEventListener('message', function(e) {if ([].concat(e.data.targets).indexOf('gdpr-host') < 0) {return
}var action = e.data.action
switch (action) {case 'set-mode-hidden':
document.body.setAttribute('data-gdpr-host-mode', 'hidden')
break
case 'set-mode-banner':
document.body.setAttribute('data-gdpr-host-mode', 'banner')
break
case 'set-mode-popup':
document.body.setAttribute('data-gdpr-host-mode', 'popup')
break
}})
}());</script></body></html>